安装编译相关软件包

apt-get install build-essential -y

安装依赖软件

apt install openssl libssl-dev libpcre3-dev libz-dev

下载源代码

wget http://www.haproxy.org/download/1.8/src/haproxy-1.8.7.tar.gz

解压

tar zxvf haproxy-1.8.7.tar.gz

进入编译目录

cd haproxy-1.8.7

编译

make TARGET=linux2628 USE_PCRE=1 USE_OPENSSL=1 USE_ZLIB=1 USE_CRYPT_H=1 USE_LIBCRYPT=1

注:1.编译之后会得到一个名为haproxy的可执行文件2.x2628是内核版本号,内核版本是4.9.3.0就是x4930

分类: Main

0 条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注